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1. Introduction 

Thank you for choosing ProtaDetails – a revolutionary automated detailing, drawing management & 

structural component design program which enables you to:  

➢ Create automated detail and general arrangement drawings from ProtaStructure models 

➢ Produce quantity take-off and reinforcement schedules 

➢ Sheet management using multiple files 

➢ Create and modify structural details rapidly with intelligent objects & templates 

➢ Run component design and detailing – such as Retaining wall, Pile cap, Stair etc. 

➢ Output to latest versions of industry standard CAD formats in DWG & DXF 

This Quick Start Guide aims to get you up and running quickly. The focus will be on creating automated 

member and plan drawings. You should be able to learn the fundamental features of ProtaDetails in 

around half an hour. 
 

2. Opening a ProtaStructure Project 

In ProtaStructure Quick Start Guide, we have analyzed and designed a simple model. We will open the 

same model in ProtaDetails to produce all the reinforcement details and general arrangement drawings.  

➢ In ProtaStructure, ensure the Quick Start Model is opened. 

➢ Go to Drawings & Reports tab → Click ProtaDetails  

ProtaDetails  will launch as a separate program.  You may close ProtaStructure.  

Alternatively, you may launch ProtaDetails from the desktop directly.  

➢ Launch ProtaDetails 2021 on your desktop 

The Open Project dialog will appear (this is identical to that of ProtaStructure open project dialog)  

  

➢ Under the Project Data Folder, pick 

Choose / Create Folder 

➢ Select the same Data Folder where 

the ‘Quick_Start_Model…’ which you 

have saved the model.  

➢ Select the project and click OK 
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If you want to open the sample completed model, then choose the default ProtaData2021 folder as 
data folder and open “Quick_Start_Guide_Concrete_Complete”. 

3. User Interface 

The main components and toolbars of ProtaDetails user interface are as shown below.  
 

 

 

 
 

The shortcut toolbars are automatically laid out according the your screen size and resolution.  

• All commands can be run from the main dropdown menu. 

• Shortcut toolbars can be re-positions by simply click, drag & dock to the final position. 

• Right-clicking on any of the command will expose the toolbars choices (you can on / off). 

• You can type in the command directly in the command box at the bottom. Command shortcuts 

can be set via Settings → Options → Command Aliases  

 

When a new project is opened, the Start Screen will appear with the following options :   

• Auto Generate Details (Detail Drawing Manager) - Automated batch generation of all 

reinforcement details of reinforced concrete members and general arrangement drawings 

• Start By Creating a New Drawing -  Open up a new blank drawing with file name Drawing1.dwg) 

• Open Project Drawing from list – Open previously generated & saved project drawings  

  

Details & Drawings 

& Macros  Start Screen / 

Drawing View 

Command line 

Main drop down menu 

 

Horizontal Toolbars 

Vertical Toolbars 

Right-click on any 

icons to expose the 

toolbar choices 

Toggle icons (on/off) 
Unit & Scale Object Snap 
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Details tab 

Drawings tab 

Macro tab 

  

The Details tab lists & organizes all the possible structure details, 

eg. Form Plans (layout) that can be produced.  

Clicking on the triangle preceding the text will expand the list to 

expose more details.  

✓ A tick means that particular detail has been inserted in a 

drawing 

Green colored member labels means the member is successfully 

designed (Red = Fail  &  Amber = Analysis out of date) 

This allows you to easily keep track of and manage details in an 

efficient manner. 

The Drawing tab list & organizes all drawings (dwg) files that 

has been created & what details the drawings contain.  

Once a particular drawing has been created & details inserted, 

it will be added in the list. Clicking on the triangle preceding 

the main folder will expose more details.  

This allows you to easily keep track of and manage drawings 

in an efficient manner. 

If you right-click on a drawing detail, there is option to “Goto 

Detail” which will locate and zoom in to that detail.   

 

 
The Macros tab lists all the engineering design macros that 

have been used & created.  

If you right-click on a macro, there are additional options to 

Edit, Delete, Goto Detail & Open Drawing directly.   
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Setting tab 

Before creating any details, it is recommended that you review Settings (top menu) such as Layers as this 

directly affects the final output.  All the layers, materials, member settings are directly inherited from the 

ProtaStructure model. 

        

Settings (top menu) → Options  contains many other settings such as Display. 

  

Click on the triangle to expose more options.  Click on Scales to examine all the default scales used.  

  

You may change any of the settings before creating the details.  Settings that are saved in ProtaDetails 

will automatically apply to the same project in ProtaStructure  (as both share the same project files).  
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4. Draw All Model Details 

The quickest way to create all the details in one go is to go to use the Auto Generate Details function in 

the Start Screen.  

➢ Alternatively, go to ProtaStructure (top menu)  → Details Drawings Manager 

 

A dialog will appear, giving you options to include or exclude the various details. Each detail has further 

option when it is selected. 

   

➢ Choose the details you want to produce by checking on the various options 

➢ Uncheck  Draw On Separate Files (so all details are inserted to a single drawing file) 

➢ Click Draw  & all the details including the plan drawings will be created 

 

➢ Close the drawing file by clicking on the x icon of the drawing 

➢ When prompted to save, pick NO  



  
  

ProtaDetails 2021 Quick Start Guide (July 2020) 8 

While this method is the quickest way to insert all the details, it may not be suitable in a real project to 

insert all the details into a single drawing.  In the following sections, we will insert various details into 

different drawing files to demonstrate how details and drawings can be managed systematically.  

5. Creating Plan / Layout Detail 

We will now create the plan details of the project and insert it in a new drawing.  
 

➢ Go to File (top main menu) → New Drawing to start a new drawing 

➢ Double-click on Detail Drawing Manager at the top of the Details tab 

        

 

 

 

 

 

 

 

 

 

 

A dialog showing options to show slab reinforcement bars, member dimensions & hatching columns will 

be shown. Foundation plan showing raft, footing & pile caps (if any) will be shown in St:0  
 

➢ Ensure that all Storeys & Form Plan are selected  

You can multiple select or deselect by holding down the CTRL key & left click continually.   

➢ Go to Options 2 & 3 tab and review all the additional settings  → Draw 

➢ Click anywhere in the drawing to insert the plans detail 

  

➢ Go to File (top main menu) → Save Drawing As      
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➢ Change the File Name to ‘Plan Layout’ and then click OK  

❖ Alternatively, to quickly generate Form Plans only :   

 

 

 

 

 

For information, if you would like to insert the plan detail of a particular storey :  

 

  

Tip : The green tick next to the storey indicates the detail has been inserted in a drawing. 2 nos. of green 

ticks indicate the detail has been inserted twice.  

6. RC slab cross sections with reinforcement detailing  

Reinforced slab cross section can be created with reinforcement detailing.  In ProtaDetails, cut sections 

anywhere along the layout plan drawing and position it anywhere within the drawing sheet.  

❖ Firstly, the slab reinforcements must be shown on the plan layout. If not, then ensure the following : 

➢ In ProtaStructure, ensure that all the slabs reinforcement has been designed using slab strips. 

➢ Go to Drawings & Reports tab →  Launch ProtaDetails  

➢ In ProtaDetails, generate the Form Plan drawing ensuring options to Show Rebars are checked 

  

Tip : More slab detailing options are available tin the Options 2 tab.  

➢ Expand the Form Plans by clicking on the 
triangle icon  
 

➢ Click of St:1 to select it → Right-click to expose 

context menu → select Draw  

 

➢ Click on a location in the drawing to place it 

➢ Select Form Plans  
 

➢ Right click  → Draw Form Plans 
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➢ Go to Detail Library (top menu) → Pick Plan Sections  

➢ Alternatively, in the Command line at the bottom, type “FormSection”  

➢ In the Section dialog, input / select the preferred options 

➢ Draw a “section cut” line by clicking on 2 points on the plan view 

 

➢ Click on the desired location to place the section detail  

Tip : Click   (orthogonal) icon at the bottom to ensure the line is exactly horizontal/vertical.   

 

7. Creating Column & Wall Schedules  

We will now produce the column/wall schedules in a new drawing.  

➢ Go to File (top main menu) → New Drawing to start a new drawing 

➢ Double-click on Detail Drawing Manager at the top of the Details tab 

  

 

➢ Check Shearwalls to include shear walls too 

➢ Go to the Options tab   

Pick Column Schedule → Filter tab dialog allows you 

choose which columns/walls to be included.  

By default, all columns of all storeys are selected.  

If you would like to re-choose particular columns / 

walls, simply hold down the CTRL key and then pick 

on individual columns & walls.   

You can also hold down the SHIFT key → Pick the 

first element → Pick the last element → all elements 

in between will be selected as well.  

 

Section A- A 

A A 
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➢ Click Draw & Click on a location in the drawing to place it (as shown below) 

 

 

 

  

❖ Alternative way to insert column schedule : 

➢ In Details tab (left pane), right click on Column 

Elevation Drawings  →  Draw Column Schedules 

The same column schedule dialog will appear 

The Options tab contains more settings that controls the 

output & presentation of the drawing. The newer options 

are explained below :  

❖ Group Similar Columns - columns with same section 

size and rebars will be grouped together 

❖ Draw Bottom Section for Slanting Column -  Adds 

additional bottom section cut for slanting column 

❖ Draw Outline of Change in Column Size – if column 

changes sizes between storeys, the outline lower 

column will also be drawn.  
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8. Creating Column Elevation Details 

We will now insert the column elevation details in the same drawing. 

➢ Double-click on Detail Drawing Manager at the top of the Details tab  

 

➢ Alternatively, right click on Column Elevation Drawings  →  Draw Column Elevations   

➢ In the Column Elevation dialog, check only Column Elevation  

➢ Go to Options tab to review more settings  → Draw 

➢ Click on a location in the drawing to place the detail 

All the columns & wall elevation details and the quantity table will be created as shown below 

 

We will now insert the combined column elevation spanning multiple storeys. 

➢ Expand Column Elevation Drawings 

➢ Expand ST: 1 → Select 1C1 or GC1 
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➢ Right click →  Draw Column Elevation (Through Storeys) 

     

Note individual column elevation and schedules options are available in the menu.  

➢ In Select Storey dialog, ensure all Storeys is selected → OK 

➢ Click on a location in the drawing to place the detail 

➢ Expand Shearwall Elevation Drawings  

➢ Expand ST: 1 → Select 1W1 or GW1 

➢ Repeat the same steps to insert the detail for the wall  (as shown below) 

 

➢ Go to File (top main menu) → Save Drawing 

➢ Change the File Name to Column Schedule & Elevation and then click OK   
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9. Creating Column Application Plans 

The column application plan shows the column reinforcement on the plan layout view. The columns will 

need to be drawn to a bigger scale than the plan view in order to show the reinforcement clearly.  

➢ Go to File (top main menu) → New Drawing to start a new drawing 

➢ Double-click on Detail Drawing Manager at the top of the Details tab  

➢ Alternatively, right click on Column Application Plans  → Draw Column Applications 

 

➢ Ensure that all storeys are selected → Pick Draw  → Click a location to place the detail 

The below shows an example of column application plan.  
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➢ Go to File (top main menu) → Save Drawing  

➢ Change the File Name to ‘Column Application Plan’ and then click OK  

For information, if you would like to insert column application plan of a particular storey :  

 

 

 

10. Creating Beam Elevation Details 

We will now insert the beam elevation details in a new drawing.  

➢ Go to File (top main menu) → New Drawing to start a new drawing 

 

 

➢ Check the option to insert the Insert Quantity Table  

➢ Check Insert to Sheet  → Pick Sheet → Choose A0_Prota.dxf in Sheet list  

❖ You can save your own sheet in C:\Users\[User]\Documents\ProtaLib\Sheets.  

By default, beams detail wider than the sheet will be auto-truncated from sheet border. 

➢ Go to Options tab  

➢ Expand Column Application Plans 

➢ Select a particular Storey  

➢ Right click on the storey →  Draw  

 

➢ In the Details tab → right click on Storey Beam 

Elevation Drawings  

➢ Pick Draw All Beam Elevations (all Axes) 
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➢ Pick how to truncate under Beam Axes Wider Than Sheet by select from drop down :  

• Don’t Truncate even if beams details are out of sheet border 

• Truncate from Sheet Border  

• Truncate The Closest Axes from Sheet Border – will ensure truncation only at axes  

➢ Check the Option to insert the Insert Concrete Beam Schedule  

➢ Click Draw → Click a position in the drawing to insert all the beam elevation details 
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The Concrete Beam Schedule shows the beam reinforcement in tabular format (as below) 

 

➢ Save the drawing file as ‘Beam Elevations’ 

Inserting beam details individually  

If you only want to insert a particular beam axis:  

➢ Expand the Storey  ST:1  

 

Inserting beam details one by one  

To insert the beam details of all axes of a particular storey in a batch mode:  

  

The beams will be listed along the design & detail axes; similar to 

the way it is presented in ProtaStructure beam design.  

➢ Select any of the beams, eg. 1B1-1B2… 

➢ Right click → Draw  

➢ Click the position to insert the detail in the drawing space. 

A green tick will appear next the beam axes to indicate the beam 

detail has been inserted. 

➢ Select St:1 

➢ Right click → Draw Beam Elevations (one by one) 

➢ Click the position to insert the 1st beam detail in the 

drawing space 

➢ Continue to click successively to position the other 

beams 

➢ Press Esc to end the process prematurely 
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11. Search a Member Detail or Text  

There are search functions quickly find, filter & locate a member detail or text, example beam 1B1.  

How To Use Search in Treeview : 

➢ Go the Details tab  

➢ Input a member label, e.g. 1B2 in the box 

Only the details with the exact name match will located & 

displayed. You can then draw out this detail only. 

➢ Right-click → Draw 

This is very useful if you only want to draw out a particular detail, not all of them. 

After drawing details or objects in the drawing, you can use the new text search function to locate it.  

How To Use Text Search :  

  

➢ Go to Edit → Search Text    (CommandLine: SearchText) 

➢ In the Search Text dialog, type the text, eg. 1C11 → Enter 

➢ Double-click on the found items & it will be located & zoomed into focus 

 You can use this function to search for all texts in primitive entities and intelligent objects as well. 

12. Drawings  

The Drawings tab keeps track of various details that have inserted and also the drawing files created. 

This will enable you to manage your project details and drawings in a systematic and efficient manner.  

  

➢ Click on the Drawings tab to review all the drawing files saved and 
what the details they contain 

➢ Click on triangle icon to expand or collapse the details 

➢ Verify that all details have been inserted  

To locate a member detail in a drawing :  

➢ Ensure that the drawing is opened 

➢ Locate the member by drilling down the triangle 

➢ Right-click → Goto Detail 

The member detail will be located and zoomed into focus in the 
drawing.   
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13. Drawing Management 

There are functions to draw and update the details which are accessible from ProtaStructure tools (top 

menu) :  

 

Update All Model Drawings – updates all the model drawings without checking if anything has changed 
in ProtaStructure model. This is a forced update. All the drawn items are forced to be regenerated.  
 
Update Modified Members Only – checks and gives a summary of all the members modified in 
ProtaStruture. If you choose to continue you get only modified members to update. 
 
Update All Plan Sections - updates all the sections of the plan view that are manually created. 
 
Drawing Summary - creates a table of drawing file names and their respective detail components.  
 
Model Info - Inserts a table showing project information summary such as materials & parameters. 
 
Concrete Rebar Schedule – Inserts the concrete rebar schedule of a particular storey. 
 
Column Link Details – Draws the link details for columns & the Quantity Table  
 
Column Rebar Details – Draws the main reinforcement column details & the Quantity Table 
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14. Dimension Styles Interface 

Dimension styles can be edited using this interface and can be saved along with the project 

➢ You can find it under Formats (top menu) > Dimension Styles  
➢ All the necessary dimension styles for detail generation will come predefined 
➢ Use “+” and “x” buttons to add/remove dimension styles 
➢ Edit them as you wish. When you click “Ok” they will be saved in the project data. There is no 

need to save project or drawing explicitly. 
 

 

 

15. Multiple selection of Tables for report generation 

Any table drawn in ProtaDetails can be converted to a report and generated via the Report Manager.  

 How To Use: 

➢ Select a table or multiple select tables (hold down 
CTRL) 

➢ Right-click → Add to Report 

➢ Give it a title → OK 

➢ The report will be created 

This particular report will also be added in the report 

repository Report Manager in ProtaStructure (under 

Other Structural Members) 
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16. Engineering Design Libraries 

Structural components design & detailing such as the Cantilever Retaining Wall, Pile Cap, Pile Design, 
Engineering Utilities, Stairs, Corbel & Pool are available via Design Libraries (top menu).  These powerful 
engineering modules provide full calculation report, detail drawings and quantities.  

Cantilever retaining wall 

  

 

 

 

 

 

 

Pile cap 

 

 

 

 

 

 

 
 

Pile Design 
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Stairs Design 
 

 

 

 

 

 

 

 
 

Pool Design 

 
 

After running the design library, close the module and click on anywhere in the empty drawing to insert 
the detail & the quantity table (if applicable).  The calculation will then be added in the Macros tab. 

If you right-click on a macro, there are additional options to Edit, 

Delete, Goto Detail & Open Drawing directly.   

Save the drawing to ensure the engineering macros are retained when 

the drawing is closed. 

 

These engineering libraries will be expanded continually to cater to your engineering needs. We 
encourage you to feedback to us what you would like to see next.  

You may continue to run the engineering libraries as outlined in the following sections.  
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16.1 Engineering Utilities for quick engineering design & calculation 

The handy Engineering Utilities can be used for quick engineering design. This includes a calculator for 

concrete cover, rebar anchorage & lap lengths; simple beam analysis tool to calculate maximum shear, 

moment and deflections; hydraulics calculator for uniform flow depth & gradually varied flow, etc.   

How to Use 

➢ Go to Design Library (top dropdown menu) → Engineering Utilities 
 

 

The following is the complete list of the modules and their functions : 

1. Cover and Anchorage Calculator   
➢ Calculates concrete cover, anchorage and lap lengths 

2. Hook Length Calculator 
➢ Calculates rebar bending, extension & total hook length 

3. Rebar Area Calculator  
➢ Calculates provided steel area per meter (e.g. 10H16 @ 100mm spacing) based on required steal 

area 

4. Unit Conversion 
➢ Converts common engineering units, eg.  Pascal (Pa) → Kilopound Per Square Inch (ksi) 

5. Simple Beam Analysis 
➢ Calculates maximum shear, moment & deflection for single span beam with various support 

condition such as simple, cantilever & fixed end  

6. Uniform Flow Depth (Hydraulics) 
➢ Solves for discharge, flow depth, channel width or channel slope for rectangular, trapezoidal or 

circular channels under ‘uniform flow depth’ condition 

7. Gradually Varied Flow (Hydraulics) 
➢ Solves for discharge, flow depth, channel width or channel slope for rectangular, trapezoidal or 

circular channels under ‘gradually varied flow’ condition 
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16.2 Pool Design / Tank Design 

The Pool Design can be used to analyze, design and detail pool or tank of various shape and sizes. You 

define different soil profiles surrounding the pool walls and apply various surcharge loads on the soil.   

How to Use 
➢ Go to Design Library (top dropdown menu) → Pool Design 

In the pool design dialog start defining the pool by starting on the left most icon and move to the right.  
 

 

1. Select from Gallery 
➢ Select the type of pool for the choices provided   

2. Points : Defines the characteristic & shape of the walls of the tank 
➢ Enter bottom & top elevation of the tank.  The difference is the tank depth.  
➢ Points table : Define the bottom joint coordinates of each tank wall. Also the curvature.   

3. Slabs : Defines the characteristic & shape of the bottom slab(s) of the tank 
➢ Points table : Define the bottom joint coordinates of each slab. Also the edge curvature 

4. Materials & Loads : Define material, code, soil model & surcharge loads.  
➢ Material : Choose Concrete grade, rebar grade & diameter for design 
➢ Settings : Choose the design code & parameters 
➢ Soil Model : Choose active or passive load side, long or short term load, water table level, etc 
➢ Soil Profile : Define the soil profile & layers 
➢ Surcharge  : Input surcharge loads (point, line, strip & surface load) 
➢ Results & Report : Print & review the analysis results of the walls, e.g  active pressure & forces  

5. Design : Design the wall and base slab of the tank  
➢ Change the wall & slab thickness & click Renew Rebar Design (if the first round of design fails) 
➢ Pick load cases to consider, e.g. post construction, operations, maintenance & earthquake 

6. Draw Details  : Draw the reinforcement details in including plan and cut sections.  

7. Print Report :  Print the entire pool reporting including geometer, analysis and design. 

8. Transparency : Shows the reinforcement in 3D.  

9. Zoom Extent : Zoom to extent of the diagram 

10.  OK : Click OK to exit and place the detail drawing into the current opened drawing.   

Pt 1 

Pt 2 

Pt 3 

Pt 4 
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17. Closing Summary 

Congratulations! You have completed your first project of automated detailing & general arrangement 

drawings production & management in ProtaDetails.  

In this Quick Start Guide, you had firsthand experience how easy it is to create all the detail reinforcement 

& layout drawings of the project model you first started in ProtaStructure. You also discovered how the 

engineering component design libraries (such as the retaining wall) enable you to efficiently produce 

comprehensive analysis & design reports and detail reinforcement drawings with quantity take-off.  

We recommend you go through the What’s New document on the new and enhanced features of 

ProtaDetails.  

There are many more powerful detailing features such as intelligent objects in ProtaDetails. For more 

help and guidance, please refer to the help reference accessible from Help menu.  

Alternatively, you can attend our training courses to obtain a more in-depth knowledge of the usage of 

the software.  Please visit our website www.protasoftware.com for more information. 

http://www.protasoftware.com/

