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Starting a new project & Import Members  

In this example a DXF drawing is imported into ProtaStructure. This drawing can then be used for the 

following features:- 

• Automatic Import of Axis  

• Automatic Import of Column Sections  

• Use the DXF  as Ghost Layer to accurately create the elements and loads 

• Snap to locations on the DXF 

• Import a different DXF at each level (St) of the structure 

• Provides quick effective checking for changes to the scheme by importing revised drawings  

➢ Create a New project with the name “Irregular_Flat_Slab” 

➢ Select ‘Malaysia (BS8110)’ template and Import to current project settings 

 

➢ Click on the ‘External Reference Drawing’ icon in the Building Setout tab 

 
 

➢ Add the given dxf file ‘Irregular_Flat_Slab.dxf’ (DXF drawing can be downloaded from this link) 

 

➢ Check Active 

The reference file is shown in the background. We will now import the axes and column using the 

Import DXF function 

➢ Click Import 

https://support.protasoftware.com/portal/api/kbArticles/306520000054398600/locale/en/attachments/dc04naf044197ba234e06af307a7ba1c8da5d/content?portalId=edbsneff51a3817fa93c6f82be8e7ba2af11e17e042278976e04371f7d6dc28158321
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➢ Under Add, check Grid and Column 

➢ For Grid Layer, choose only AXIS & AXIX2   

➢ For Grid Text Layer, choose on AXIS & AXIS2 

➢ For Column Layer, choose only COLUMN 

➢ Click Import  >  Close > OK to close the dialog 

The grids columns will be imported as shown below with external drawing in background.  

 

If the external reference drawing is not shown in background, click Refresh  icon (leftmost icon just 

above the structure tree) 
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To get a less cluttered view, switch off the background grid & grid dimensions.  

➢ Go to Review tab > Visual Interrogation > Scene Settings > Uncheck ‘Grid’ & ‘Show Auto Dimensions’ 
> OK  

 
 

The background grey grids & grid dimensions will be switched off.  

Generate Load Combinations 

We will now proceed to setup the load combinations before proceeding to create other members. 

➢ Loading tab > Load Cases  and Combinations 

➢ Click Loading Generator > Vertical Load Combinations > Use all defaults. 

➢ Go to Horizontal Load Combinations > Check “Notional Loading”  > OK 
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The combinitions will be generated as shown below. 

 

➢ Click OK to save & exit the dialog.  

Create walls & beam 

➢ Create 250mm thick core walls and a 250mm x 500mm beam as shown below 
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Inserting slabs 

There are different techniques for inserting slabs. The options can be changed in Slab Properties > 

General tab > Insertion. Each one has its own merits; which to use is your decision.  

 

Important! Before creating the slabs in a Flat Slab model it is paramount that the layout of the slab 

panels is given consideration, and the following guidelines are met : 

• All Walls and Beams (if any) must  lie on slab boundaries or edge; i.e. a wall or beam must not 

overlap with any slab.  

• Columns can sit within slab panels; i.e. a column can overlap with slab. 

• Slab boundaries sharing the same grid line will be continuous in the FE model 

• Slab panels should be as large as possible (lots of small panels will complicate the FE) 

• Slabs should have the minimum edges possible (triangle/square/rectangle). Irregular shaped 

panels L, etc. should be avoided 

• There is No Right or Wrong layout for the slab panels, but by adhering to the above, slab layouts 

should be simple and effective when entering the FE environment 

• Ignore the yield-lines shown on the plan view (they are only valid if the slabs are supported by 

beams). 

 

➢ Insert all 300mm thk. slabs with an Additional Dead Load of 0.5kN/m2, and an Imposed Load of 

3kN/m2. 

➢ Proceed to insert ST04 via Building Setout tab > Storey Operations > Insert Storey 

The final model will have a total 4 storeys with each storey height = 3000 mm.  

• Axis Region: Insert slab based on the nearest axes as boundary. 

Hold own CTRL & pick several axes region to combine > Release 

CTRL key & single slab in the combined region will be created. 

• Beam Region: This is of no use for flat slab models due to the 

absence of beams. This is to be used only for beam & slab model.  

• Pick Axis: Select the axes one by one consecutively in clockwise 

order to define the boundary of the slab > Ensure they are listed 

in the box > Pick back the first axis > Slab will be auto created. 

• Pick Points: Pick the intersection of axes that forms the corner of 

the slab in clockwise order > Once the loop is closed, the slab will 

be auto created.  

• Pick Closed Slab Edge: Insert the slab using closed slab edge line 

without need for surrounding by grids.  Slab edge lines must be 

created first, e.g. using Polyline Slab Edge function.  

If slabs cannot be inserted by any of the above methods, click “Delete 

All Axes” & start again. Also, try closing the slab properties & start 

again.  
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➢ Make all ST01, 02 & 03 storeys similar via Building Setout > Storey Operations > Edit Storey  (Multiple 

select 3 Storeys & click Define Selected Storeys as Similar) 

 

ST04 cannot be similar storey because it’s the roof & hence both plan & elevation are not similar to 

rest of the storeys.  

➢ For ST04, go to Building Setout > Storey Operations > Generate Storey > Copy all members from ST01 

(Source) to ST04 (Target) 
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Before & after copying any storey’s information to the other floors, it is suggested to perform the 

Building Model Check.  

➢ Go to the Review tab > Click  Building Model Check 

 

Final Flat Slab Model 

This is the Flat Slab Model that will be analysed and designed as shown below : 

 

Consider the model shown above. A core wall system is assumed to brace the structure and therefore 
the flat slabs and peripheral columns are predominantly to be designed for gravity loads only.  

Although it looks like a simple layout, it would be very difficult to apply the idealisation of column and 

middle strips; hence, it becomes almost impossible to apply the BS8110 code’s simplified design 

methods. Therefore, the ProtaStructure Finite Element Analysis is going to be used to determine the 

gravity Loads on the slabs, columns and walls. 

➢ Uncheck “Column Inside Slab Panels” 

This check is for beam slab layout. For flat 

slab, the columns can overlap with slabs, 

hence we uncheck this option.  

➢ Click Start to check  

Ensure there are no errors. If there are 

errors, you can click “Load Log to Editor” 

to show the errors in separated NotePad 

so it’s easier to refer for correction.  

➢ Click Close to exit.  
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➢ Continue with the model you have setup in the former section, or use the given model ‘Irregular Flat 

Slab’. (Zipped model can be download from link) 

Material Properties 

➢ Go to Building Setout tab and click Materials 

➢ Click on the Concrete Grades button for Slabs 

➢ Select C40 making sure the Short term Modulus of Elasticity = 28000 N/mm2 

➢ Make sure the Unit Weight of Concrete = 24 kN/m3 

➢ Tick the ‘Apply to All Member Types’ 

➢ Click OK in the ‘Concrete Grade’ window 

➢ Using similar techniques as used to change the Concrete Grades, specify Grade 500 steel with a Steel 

Material Coefficient of 1.15 

➢ Check the Bar Sizes for Slabs are set to H10/H12/H16/H20/H25/H32 

➢ Click OK in the ‘Material’ window 

➢ All element types have a Consistent Set of Section Properties 

 

 

 

These settings for the Material Properties apply to both the Building Analysis and the Finite 

Element Analysis. 

https://support.protasoftware.com/portal/api/kbArticles/306520000054398600/locale/en/attachments/dc04n07b252674f09421ea5b59a4511589901/content?portalId=edbsneff51a3817fa93c6f82be8e7ba2af11e17e042278976e04371f7d6dc28158321
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Flat Slab Analysis & Design Flow Chart 

Flat slab analysis & design can be done using either of 2 methods  :  

A. Building Analysis with floor slab meshed 

B. Finite Element Floor Analysis Chasedown + Building analysis without floor slab meshed 

The difference in the analytical model is as shown & summarized below.  

 

A.  Building Analysis with floor slab Meshed 
B.  FE Floor Analysis Gravity Load Chase down + 

Building analysis without floor slab meshed 

Full 3D model top to bottom storey, with floor slab 

meshed. There is option to mesh only selected 

storeys.  

FE Floor Analysis analyses 1 storey only, i.e. subframe 

analysis. 

Single analysis to obtain both lateral and gravity load 

results.  

FE Floor analysis gives gravity load results only. 

Hence, need to run Building Analysis (without 

meshing floor slabs) to obtain lateral analysis. 

3D effects such as differential axial deformation effect 

or natural sway due to gravity loads included.  

Hence, results may deviate from traditional or 

conventional assumption of flat slab. 

3D effects are excluded since analysis involves only 1 

storey at a time.   

Hence, result is more in line with traditional or 

conventional flat slab analysis. 

Analytical model is larger & more complex if floor plan 

is large with many storeys. 

Hence, may be harder to identify modelling mistakes, 

as need to examine the full 3D analytical model.  

FE floor analytical model is smaller & simpler since 

only 1 storey is considered at a time.   

However, more steps are required since both building 

analysis & FE Floor Gravity Chasedown must be done. 

More efficient as single analysis for gravity & lateral 

loads or for models where only certain floors are flat 

slab. 

More suitable when traditional subframe assumption 

preferred. 

+ A 

B 
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Flat Slab Analysis using Building Analysis with floor slab meshed 

The following are summary of steps using this method :  

1. Model the flat slab model using slabs as outlined in the previous section. 

2. Go to Building Analysis > Model Options > Slab Model 

 

• Tick ‘Include Slabs in Building Model’ > this will mesh the floor slabs 

• Select ‘Storeys to be Meshed’ > Select all storeys.  

• Review other parameters such as Shell Element size & Slab Stiffness Coefficients  

• The defaults for this model is 0.25 or 25% for In-plane & Bending (out-of plane)  

• For detail explanation of each parameter, kindly refer to Prota Help center : Slab Model 

3. Run Building Analysis 

• This will give results of gravity (G+Q) and lateral (notional + wind) 

• Go to Building Analytical Model to review & verify the results. 

➢ Perform Building Analysis with all the settings shown above (without performing any member 

design).  

After analysis is completed successfully, drift check summary will be shown. If the model is set up 

correctly, the drift check should pass. For details of the drift check, you can generate the Post Analysis 

Checks report.  

You should also review Axial Load Comparison Report to check whether any gravity loads are lost. This 

is already covered under the ProtaStructure Basic Training; hence please refer to it if you have not 

already done so.  

  

https://support.protasoftware.com/portal/en/kb/articles/model-options#Slab_Model:~:text=use%20%22Mid%2DPier%22-,Slab%20Model,-Parameters%20related%20to
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Slab Meshing 

Long Term Deflections 

Adjustment to the slab stiffness to cater for long term deflections are recommended in 2 references: 

• Concrete Society TR58 – Deflections in Concrete Slabs and Beams 

• The Concrete Center (HTFS) – “How to Series” – How to Design Reinforced Concrete Flat Slabs 

using Finite Elements Analysis.  

HTFS & TR58 – Recommends linear elastic analysis 

• ProtaStructure currently uses linear elastic analysis. 

• This is the simplest analytical method discussed in the report. So, it should be the simplest for 

you to use.  

• It should only be used to show that deflection is not critical, rather than for providing ‘true’ 

deflection estimates.  

• For this method a long-term elastic modulus should be used.  

HTFS – Recommends adjustment of E 

• Creep cracking and shrinkage are all factors that affect the long-term deflection of concrete.  

• Short term E (Est) should be reduced to allow for these factors, a long-term value (Elt) should 

be used in analysis. 

• HTFS suggests: 

- For office/ residential : Elt = 1/4 Est 

- For storage/ plant : Elt = 1/6 Est 

For more guidance on stiffness adjustments, kindly refer to this article in Prota Help Center : Effective 

Stiffness Modifiers  

Building Analysis Model  

➢ Close the building analysis dialog > go to Analysis tab > click Analytical Model.  

The building analysis Analytical Model shows the analytical wireframe & results of analysis. For details 

of all the icons of this view, kindly refer to this article in Prota Help Center : Analytical Model  

All the floor slabs and shearwalls are meshed using finite element shell.  It is highly recommended to 

carefully examine the Displacement, as slabs are the key structural element for flat slab models. 

Specifically, check if the shape & magnitude of the slab deflection are reasonable. 

The view is quite congested, hence let’s show only Storey 4 elements & the displacements.  

➢ In the left Filter pane, check only Storey 4. 

➢ Go to Results tab, click “Displacements”. You can Increase or Reduce Scale or enter scale after 

switching off the Auto Scale.  

➢ Pick Load Combination ‘[1] 1.4G + 1.6Q’ at the right pane.   

The displacements of the chosen load combination will be rendered in red.  The maximum resultant 

displacement will be show at the bottom.  

https://support.protasoftware.com/portal/en/kb/articles/effective-stiffness-modifiers
https://support.protasoftware.com/portal/en/kb/articles/effective-stiffness-modifiers
https://support.protasoftware.com/portal/en/kb/articles/post-analysis-ps-2022
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➢ Animation is very useful to visualise the deformation of slab in motion, e.g. observe if the slabs is 

indeed deforming as connected entities. 

➢ Turn off Displacement after due verification.  

➢ Go to Contours tab & Click Contours > Under Effects, select “Displacement Z” (global) 

➢ Click “Top” on the 3D cube to lock to plan view   

➢ Alternatively, click Plan View  (located in General tab) to lock the view in plan mode.  
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The Contours icon group has options that can be on / off by clicking on button : 

• Coloured Lines: Add line between contours 

• Line Contours: Draw line contours 

• Display Values on Lines : Show the values of line contour 

 

Contours render & display can be changed using Display group icons. Legend parameters can be 

changed and Legend group icons.  

 

➢ Placing the mouse cursor on a slab mesh will display its parameters & the value of the effect. 

 

Bottom steel reinforcement provision 

We will start by assuming that the whole slab is to be reinforced orthogonally in the Global X and Y 

directions. At this point the slabs reinforcement angles have not been adjusted, so Direction 1 steel is 

aligned with global X, which runs from left to right in the view below.  

➢ Select Effect under “Required Steel Area (Wood-Armer)”, Asd1-Bot”  & also ensure Standard 

Contours is activated. 

It is recommended to always refer to plots that include Wood & Armer adjustment i.e. torsional effect 

of slabs included. These are denoted with “d” = design, e.g. Asd… 

➢ Under Load Combinations select the desired design combination, e.g. “[1] 1.4G+1.6Q”  

Alternatively, if you like to design for envelope of all load combination for the bottom steel, choose 

Envelope (Max) 

➢ Click “Show Min As in Rebar Contours”  to show minimum required steel for the selected 

code.  We recommend to perform a manual check to ensure this value for extra precaution.  

The view (below) shows design bottom steel requirements in direction 1 with the minimum steel of 

390mm2/m as lowest 1st contour. As might be anticipated the peak requirements are occurring along 

the longest free edges. 
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The legend shows the maximum value is 1225 mm2/m. We can zoom in the contour view to try to 

find this node, usually maximum value occurs between supports or at the column or wall node.   

➢ By zooming in the column 4C4 (right corner), we can locate this value by placing the mouse 

cursor on the column boundary node & reading the tooltip as shown below. 

 

➢ Zoom into the areas between the columns where the maximum Asd-Bot should occur, i.e. 

locations where maximum slab deflections occurs (switch to Displacement Z contour to check) 

 

It is unreasonable to expect maximum Asd1-Bot to occur 

at the column node; it should be at middle of slab where 

maximum sagging deflection occurs.  

This is due circular column being simplified as hexagonal 

element & the slab shell meshed to the boundary of the 

column.  This causes a local distortion at a single node. 

If you read the adjacent node, it immediately drops to 

minimum steel.  

This abnormal value can be ignored, as any single 

abrupt & extreme jump in node value will be deem 

unreasonable.  

We can locate this node somewhere between 

column 4C1 and 4C4. The value is 893 mm2/m.  

The other similar maximum value is at the lower 

slanting slab between column 4C3 & 4C4.  The 

value is around 879 mm2/m.  

We can conclude the reasonable Asd1-bot is 

around 900 mm2/m. 
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➢ Select Effect Asd2-bot  

Using the same inspection & reasoning as direction 1, we similarly locate the correct slab nodes 

values for direction 2.  The maximum Asd2-Bot value is around 840 mm2/m at the slanting slab edge 

between 4C3 & 4C4.  For simplicity, we will use the larger 900 mm2/m as maximum of both Asd1-

Bot & Asd2-Bot.  

User Defined Contours 

➢ Switch back to view Asd1-bot. 

We can now use the custom contours option to show where different steel reinforcement 

provisions would be adequate. In general, the strategy would be to decide on general lower level of 

reinforcement to be provided continuously throughout the slab and identify the regions where an 

increased provision is required. 

➢ Click on the User Defined Contours icon and Edit User Definitions button. 

 

➢ Set Number of Contours to ‘4’ and Legend to ‘Both’ > click Update button to re-interpolate 

contour values. We choose 4 no. because we intend to provide 2 different steel contours (the 

other 2 no. is auto-calculated min & max contour). 

  

Effect – This is the brought through from the current view selected in the FE Post Processor. 

Loading – The current Load Case or Combination selected in the FE Storey and Foundation Models 

Legend – This  allows the user to choose the information displayed on the legend within the FE 

Storey and Foundation Models – E.g. Contour Value only (565.5mm2/m) / Contour Label only (H10 

– 200) / Both  
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Contour Count – This allows the user to specify the number of contours to be displayed on the 

screen. Note that Minimum (0.0) and Maximum cannot be changed. 

Contour Label/ Contour Value/ Diameter and Spacing – This  area allows the user to select bar sizes 

and spacing’s for the creation of the contours. The labels and values are automatically created based 

on the selected size and spacing of the reinforcement. 

➢ Enter the contour settings as shown below and click on Update for each input. 

   

The 1st contour should satisfy As min steel = 390 mm2/m. H12-200 = 565 mm2/m satisfies this.  

The 2nd contour must satisfy the Asd-1-Bot maximum = 900 mm2/m. H12-200 + H12-200 = 1130 

mm2/m safisfies this. This is effectively H12-100 but we choose to display as the former.  

➢ Click OK to view the Reinforcement Requirements for the Bottom Steel, in Direction 1 (Global X 

axis in this case).  

If the contour legend is hidden you can click on “Position” under Legend icons to shift it to another 

corner. The legend size can also be increased or decreased. 

 

H12-200 

H12-200   

+ H12-200 
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The “Blue” region is where H12-200 is required. The “Green” region is where H12-200 + H12-200 is 

required.  Effectively, this means H12-200 is placed in in the entire slab, while H12-200 added in 

specific “Green” area. This effectively means the “Green region” requires bar H12-100. “Amber” 

region indicates area where the provided steel is insufficient; we can ignore this (if any) as we 

already determined the reasonable maximum value.  

Creating contours (bottom steel provision) 

➢ Using the same “Edit User Definition” method, create the Asd2-Bot contours 

➢ Create two contours H12-200 and H12-200 + H12-200.  

 

In short, H12-200 & H12-200 + H12-200 satisfies both the bottom steel in direction 1 and direction 2.  

These requirements can be simply communicated to the detailer by display the above contours to plan 

view and then export to DXF. 

➢ Go to Review tab, click on Visual Interrogation > FE Contours , select contours type, effects and 

load combinations based on preferences.  

Alternatively, you can “Copy Picture” or “Save Picture” located at General tab to save the image of the 

contour by clicking respective icons in top menu.  

Although only 2 reinforcement provisions have been shown in the above example, if required many 

more contours could be introduced to suit specific project requirements. 

  

H12-200 

H12-200 + 

H12-200 
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Creating contours (top steel provision) – Asd1-top 

➢ Switch back to view Contours for Asd1-top  (same factored load comb 1.4G+1.6Q) 

 

As expected, a review of the top reinforcing requirements shows that in theory, only minimum steel is 

required over large areas of the slab (blue region) and that the hogging moments intensify rapidly over 

the column heads & core wall. The minimum steel is 390 mm2/m. For economy, H10-200 = 393 mm2/m 

would suffice as base top rebar everywhere.  We should now locate the maximum top steel by zooming 

in columns & walls where peak top rebars are expected.  

➢ Zoom in 4C4 & place mouse cursor on slab shell to locate the maximum Asd1-Top 

 

Manually calculating average of all peak slab shell nodes is tedious. The more practical way to deal with 

these peak requirements is to integrate (average) results in strips cut across the column & wall heads 

which is in line with simplified “Equivalent Frame” method stated in most of code practice.  

This can be done by using ProtaStrucure Finite Element Integral Strip. The purpose is to calculate the 

design moments using integral approach, i.e. to average out the moment within the strip width, 

otherwise the maximum moments of a single node within the strip range will be used for rebars design.  

The peak As is around 4740 mm2/m.  

It would be impractical to provide top steel 

exactly to match this peak maximum steel 

area as these a very small localised area 

often exposed when meshing slabs. 

The average of this mesh nodes is 

(4740+4727+2649)/3 = 4038 mm2/m 

If we calculate the average values of all the 

peak slab shell nodes connected to the 

column, it is around 2500 mm2/m.   
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• Refer to the figure above;  by default, the maximum peak nodal moment will be used for finite 

element slab design, i.e. column center line. 

• Integral option will average the design moment across the width of the strip. 

• The wider the strip, the lower the “averaged” design value, esp. at support region where the 

moment changes rapidly. 

• User should carefully evaluate how wide to create each strip when integral is chosen. 

In the discussion below a 2m wide strip is cut across the head of the most critical internal columns. 

➢ Go to Plan view, ensure the active storey is Storey-04 

➢ Click “Slab Strip” icon in Modelling tab, ensure that below options are set to create an Integral 

FE slab strip with 2m width :  

• Type = FE Strip > Select “Fixed Band Strip” 

• Analysis Results Source = Building Analysis 

• Scope Width Left & Right = 1000mm (total 2000mm) 

• Check “Integral”  

 

➢ Click the 1st point & then 2nd point of slab edge, making sure to cut through exactly the middle of 

columns 4C9,4C1 & 4C4.  
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➢ If the slab strip created is according to the settings set as above, program automatically designs 

& provides H16-100 (top) & H10-100 (bot) to cover the area of the slab strip width.  

Note: When this steel is provided, it must be provided over the full extent of the 2m width strip. 

The fixed band strip design provides a single top and bottom bar across the entire length & 

width of the strip. Practically, this is uneconomical design (too conservative) as the required 

steel contours shows minimum steel is already sufficient for large area of slab. Hence, it’s not 

advisable to adopt this as final steel arrangement, especially the top rebars.  

➢ Select the slab strip > Right-click > Slab Strip Check Design to launch Slab Analysis & Design dialog 

 
From the above design dialog, the required top steel reinforcement is around 1683 mm2/m.  This 

value is significantly lower than the previously manually calculated average mesh nodes connect to 

the column boundary of 2500 mm2/m. This is because the 2 meter slab strip is averaging over many 

more shells beyond the column boundary. We will now compare the various slab strip width results. 

Slab Strip 

half width 

Slab Strip 

total width 

As Required 

(mm2/m) 

Remarks 

1 m 2 m 1683 Likely too wide, as column size is 500mm.  

500 mm 1 m 2358 Lower bound, more reasonable 

250 mm 500 mm 3200 Upper bound,  too conservative?  

As expected, the narrower the strip, the higher the required area of steel. The final choice of slab 

strip width is an engineering judgement and factors to consider are :  

• Code of practice & design guidance, which will specify some idealized strip width in 

accordance with traditional analysis & design method. For example BS8110 suggests a 

certain percentage of panel width on each side.  

• Compare with manual average peak nodes of 2500 mm2/m, the 2m total width strip is likely 

to wide and unconservative. The 2m wide with is 4 times the column size of 500mm.  

• Size of support :  The size of the column is already 500 mm, hence 500 mm total width is 

likely too small & over-conservative.  

The 1000 mm total strip width As required of 2358 mm2/m is close to the manually computed 

average of 2500 mm2/m. This seems to be the most reasonable. The design top steel of H20-125 = 

2513 mm2/m is sufficient.  

➢ Now, apply the same process to horizontal wall area. Create a slab strip across the wall. It 

is found that the required steel area is around 1515 mm2/m when the total slab strip total 

width is 1000mm.  

 

  

The FE fixed band strip can only be used if cut across slabs with the same thickness.  The reason is the 

design only detects the slab thickness nearest to the first end of the strip. If three are many slabs with 

different thicknesses, then do not use the FE Slab Strip.  Use the other method of design using the As 

required contours as outlined in this Flat Slab training manual. 
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Slab Strip Diagram  

To review slab strip force diagram in Analytical Model :- 

➢ Go back to the “Building Analysis Model” view 

➢ Go Contours tab, deactivate all the Contours to get a clean view.  

➢ Go to Result tab, select slab strip you want to review from the Slab Strip List  

This will display the moment diagrams of selected strip on the analytical view. 

 

➢ To view the detailed profile, select a slab strip >  Right-click > select "Slab Strip Diagram Profile". 
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Program provides 3 different result collection methods namely Maximum, Integral, and Strip Line. 

Approach Description 

Maximum 
Maximum values of the transverse nodes at each station are used in strip result 

calculation 

Integral 

Calculates the integral of transverse node results yielding more economical and 

smoothened values. 

Note: This method only available for “Fixed Band” strips 

Strip Line 
This method is solely for checking purposes and doesn’t account for transverse 

nodes displaying the values exactly at the station nodes 

Note : Slab Diagram can also be accessed via the Slab Analysis & Design dialog.  

Having gathered all the reinforcement steel area for column and shearwall above, we can add more 

contour to satisfy the required steel area.  

We will add User Defined Contours according to satisfy the top reinforcement required:  

➢ Click “Edit User Definitions” again, and increase Contour count to 5, and click “Update” 

➢ Update the 1st  contour with reinforcement rebar H10-200  

➢ Update the 2nd contour with reinforcement rebar H10-200 + H16-200  

➢ Update the 3rd contour with reinforcement rebar H20-125 to satisfy all the areas at shearwalls 

and columns heads.   

 

Upon closer inspection on the contour plotted by zooming into columns, you can still see “red” area 

which suggests the contours created are not adequate. This would be the case if we were considering 

every peak node value for the floor plate, which we have established it not feasible nor practical.  

As such, we have chosen to design these areas using average results, the red area can be ignored & we 

can provide the same maximum reinforcement established earlier.  

For practice, the same steps can be repeated for Asd2-Top using User-Defined Contours. 

  

H10-200 

H10-200 + H16-200 

H20-125 
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Flat Slab Analysis using FE Floor Analysis Chasedown  

FE Floor Analysis is an alternative to Building Analysis with floor slab meshed. The following are summary 

of steps using this method :  

1. Model the flat slab model using slabs as outlined in the previous section. 

2. Go to Building Analysis > Model Options > Slab Model 

• Untick ‘Include Slabs in Building Model’ > Floor slabs will not be meshed 

3. Run Building Analysis (BA) 

• This will give results of gravity (G &Q) and lateral (notional + wind) 

• Gravity results are not valid since BA requires beams to supports slabs 

• Lateral results are valid as lateral loads are transferred via rigid diaphragm formed by slabs 

• Go to Building Analytical Model to review & verify the lateral analysis results 

4. Run FE Chasedown Analysis for Gravity Loads 

• Since BA cannot evaluate flat slab gravity loads, we need to run FE Floor Analysis to obtain 

gravity load results 

• FE Floor Analysis analyses a single floor with slab meshed. To correctly accumulate column & 

wall loads, we need to run the process from top to bottom storey (gravity load chase down) 

• Go to FE Analytical Model to review & verify the gravity analysis results 

5. Merge the results of both analyses for column & wall or beam design 

• Lateral loads results will be from Building Analysis 

• Gravity loads results will be from FE Floor Analysis Gravity load Chasedown 

 

Building Analysis to Generate Lateral Design Forces 

We will now proceed to analyze the flat slab system using FE Gravity Load chase down method.  

We will setup the materials & options before running Building Analysis: 

➢ Analysis tab > Building Analysis 



Page - 27 

 

➢ Go to Model Options > Settings > ShearwWall Model tab > Pick “Mid-Pier”. 

Since we are not meshing the floor slab in Building Analysis, it is not necessary to use FE Shell for 

walls. This will make the analysis run faster without sacrificing accuracy.  

➢ Go to Analysis tab > Click Building Analysis > Run Building Analysis 

➢ Ensure the Column/Wall and Beam Reinforcement Design is ‘Unticked’ 

At the end of the analysis process, you should see a warning indicating load has been lost. 

 

This warning will always appear when running Building Analysis for flat slabs. It indicates that an FE 

analysis is required for the gravity loads.  Hence, this message can be ignored. 

In the Building Analysis the slabs are replaced with rigid diaphragms to decompose the lateral loads to 

the Columns/Walls in the structure. 

➢ In the Analytical Model, you can switch on “Diaphragm” > Select the Notional Horizontal load 

load case Ngx or Ngy > The nodal loads Fx or Fy will be shown to applied at center of 

diaphragm of each storey (as shown below). 

 

Hence, in building analysis ONLY the lateral design forces have been calculated correctly.  
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As the flat slab has no beams as supports, there is no means of calculating the vertical slab loads onto 

the Columns/Walls. Therefore, for vertical / gravity loads, we need to perform FE Analysis Gravity Load 

Chase Down for the structure to obtain the correct gravity results. 

➢ Go to Analysis tab > Click FE Floor Analysis > Run Building Analysis 

FE Floor Analysis Settings 

‘Include Column Sections in FE model’ – This allows the Finite Element Mesh to form around the 

perimeter of the columns, producing moments at the face of columns rather than the centre of the 

columns. This option significantly reduces the peak hogging moments over the column heads in Flat 

Slab Construction. This option is automatically activated for flat slab model.  

‘Consider Beam Torsional Stiffnesses’ – This allows the torsional stiffness of any beam members to be 

considered in the design. Un-ticking this option would assume the beams to have No Torsional Stiffness. 

‘Include Upper Storey Column Loads’ – This option must be selected to allow the Load to be chased 

down through the model (even at the top storey). 

Shell Element Size: This controls the minimum and  maximum size of the mesh. Generally, the smaller 

the mesh, the higher the number of total mesh & hence longer analysis time. 

The key objective is to choose an ideal balance of minimum and maximum Shell Element Size and to 

produce minimum number of plates but still sufficient to accurately replicate the “true” behaviour of 

the slab (so analysis time is minimized). Generally, try to achieve between 8 plates between the column 

heads. The default of minimum 500mm a& maximum 1000mm shell size should be sufficient for most 

models.  

 

➢ Click Cracking Creep icon to calculate the stiffness adjustment  

➢ Enter Average Dead Load = 7.0 & Average Live Load = 3 > OK 

Stiffness adjustment of 0.33 will be automatically calculated for all members. The theory behind this 

is explained in this article : Cracking and Creep Factor Calculator  

➢ Tick the option “Display Analytical Model Before Analysis” 

➢ Click ‘Floor Mesh and Analysis’ button > FE Analytical model will be shown as below.  

https://support.protasoftware.com/portal/en/kb/articles/column-wall-model-types-stiffness-factors-cracking-and-creep
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The FE Analytical model is for 1 storey only. You can verify the analytical model by zooming in area of 

concern, example ensure the elements are connected properly. As mentioned previously, we should 

have recommended 8 shells between columns or supports. Hence, the default shell size setting is 

sufficient.  

➢ Click OK to close & complete the analysis 

Batch FE Chasedown Analysis 

The previous operation could be performed at each floor level by analysing and moving to the floor 

below until the load has been transferred to the foundation level. However, using the ‘Batch FE 

Chasedown’ this procedure can be automated: 

➢ Select All Storeys and ensure option “Include Upper Storey Columns Loads” is ticked.  

 

➢ Make the settings as shown above > Click Floor Mesh and Analysis 

Storey will be highlighted as green colour when FE Floor Analysis is completed.  
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If “FE Chasedown” is performed, “▼” will be displayed next to the storey. Otherwise, it will be 

greyed. 

➢ Un-tick the ‘Display Analytical Model Before Analysis’ as the floor plates are all the same in this 

model, so there is no need to check and approve the Mesh at every floor level. 

It maybe that you choose to “Display Analytical Model Before Analysis” for the first FE run of 

the Load Chase Down. However, after minor changes, you may well un-tick this option.  

➢ Once FE Chasedown of all storeys is completed successfully, tick ‘Merge Column Results with 

Building Analysis Results’.  

 

This ensure that all column and wall gravity (vertical) loads will use FE Floor Analysis results; 

otherwise, gravity loads will still be based on Building Analysis (wrong!). 

The option to also ‘Merge Beam Results…’ is optional & is a user decision if there are also 

beams in the model. 

➢ Click Close to exit the dialog.  

  
Important! 
When “Merge Column / Beam Results with Building Analysis Results” is checked, is mandatory to “Close” 

the dialog for the FE Chasedown Results to ensure all the associated member forces and reports to be 

updated.   
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Reviewing Column & Wall Forces on plan view 

➢ Go to ST01 Plan view.  

➢ Go to Review tab > Visual Interrogation > Column Plan Display > Check Axial Load  

➢ Under Load Combination dropdown >  Pick ‘[1] 1.4G+1.6Q’  > Click OK  

The Axial load for the selected combination will be shown on plan view as below. 

 

Displaying column / wall forces on the plan view is a convenient way to check member forces.  For 

above column 1C1, the axial load value does seem reasonable when cross-referenced against the Axial 

Load Comparison Report.  

Other methods of reviewing column or wall forces are :  

❖ Select Column / Wall > Right-click > Pick Analysis Results Diagram >  Dialog shows all the force 

diagrams of all load cases and combinations.  

❖ Select Column / Wall > Right-click > Pick Column / Wall Design Forces > Report will be 

generated listing down design forces. 

Verify the results 

When FE Floor Analysis is successfully completed, we can go to “Post Analysis Processes and Report” 

tab to review or check the results & reports.  

➢ Go to Analysis tab > Click FE Floor Analysis to relaunch the FE Floor Analysis dialog.  

➢ Click on “Post-Analysis Processes and Reports” tab 
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Positive Moment Factor  

For FE Floor Analysis Models it should be noted that they do not include for the effects of Pattern 

Loading. It is not feasible to automate pattern loading to generate every possible worst case scenario 

for every conceivable irregular arrangement. If you are concerned about the effects of Pattern Loading 

we suggest amplifying the ‘Positive Moment Factor’ (10 to 20% i.e. 1.1 to 1.2) to allow for these 

effects. Please note if a factor is applied, “Floor Mesh and Analysis” must be repeated.   

➢ Leave the factor as 1.0 for now.  

➢ Click Axial Load Comparison Report 

➢ Check values of Table 1 : Total Loads (Input Loads) is close to Table 4 : Finite Element Analysis 

Columns/Wall Axial Loads (Output Loads). 
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Ignore Table 2 & Table 3 (& the warnings below the tables) as it is only applicable to beam slab model 

which requires results from Building Analysis. 

If there are large discrepancies between sum of Table 1 & Table 4 it may mean that the flat slab model 

is set up incorrectly & hence loadings are lost.  

➢ Click “List Maximum Storey Displacements” button at the bottom of the dialog. 

 

FE Floor Model  

➢ Click “Display Analytical Model” in the Post Analysis  to access the FE Floor Model.  

➢ Alternatively, go to Analysis tab > Analytical Model > Pick FE Floor Model 

 

This will create and open the FE Model view (as shown below)  

 

This functions & icons is the same as the Building Analysis Model, except that the FE Model is a single 

storey model.  Under the left filter pane, >>> shows the current active storey.  

➢ Pick on “Storeys” number in the Filter pane to view another storey.  

The methods to show different contours are exactly as covered previously. Experiment with viewing the 

various Contours & setting up the various User-Defined Contours, as covered previously.   

The table shows the maximum Positive and 
Negative Displacements of all the floors for 
the 1st combination, [1] 1.4G+1.6Q. 

Positive is upwards while negative is 
downwards, in accordance with the global Z 
direction.  

Pick Storey to view 
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Column Punching Check  

Column punching shear check must be done after the flat slab reinforcement is determined, as required 

by the design code.  

➢ Go to Design tab > Pick Column Punching Check   

If no column is selected, then all columns will be included in the check. If you only want one or some 

specific columns, then select multiple the desired columns before clicking on this function.  

 

 

 

Slab Design with Slab Patch Panels  

Based on the function of FE Fixed Band Strip, ProtaStructure has a new feature that allows users to apply 

a Base Reinforcement throughout the entire floor and design additional top or bottom bars at column 

support regions. This powerful new feature is called the Slab Patch Panels. 

The example of the final output that can be achieved is shown below. 

 

 

  

For details on the checks kindly refer to these articles in Prota Help Center :  

▪ Column Punching Check  

▪ Column Punching Shear Checks to BS 8110 and Eurocode 2  

 

For details kindly refer to this article :  Flat Slab and Raft Design with Slab Patch Panels 

Slab Patch Panels 

https://support.protasoftware.com/portal/en/kb/articles/column-punching-check
https://support.protasoftware.com/portal/en/kb/articles/column-punching-shear-checks-to-bs-8110-and-eurocode-2
https://support.protasoftware.com/portal/en/kb/articles/flat-slab-and-raft-design-with-slab-patch-panels
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Thank You… 

Thank you for choosing the ProtaStructure Suite product family. 

It is our top priority to make your experience excellent with our software technology solutions.  

Should you have any technical support requests or questions, please do not hesitate to contact us at all 

times through globalsupport@protasoftware.com and asiasupport@protasoftware.com  

Our dedicated online support center together with our responsive technical support team is available 

to help you get the most out of Prota’s technology solutions.  

The Prota Team 
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